Caché fits into all common high-availability configurations supplied by operating system providers including Microsoft,IBM, HP, and EMC. Caché provides easy-to-use, often automatic, mechanisms that integrate easily with the operating system to provide high availability.There are four general approaches to system failover. In order of increasing availability they are:
• No Failover Strategy
• Failover Cluster
• Concurrent Cluster
• ECP Cluster
There are variations on these strategies; for example, many large enterprise clients have implemented ECP cluster and alsouse failover cluster for disaster recovery.It is important to differentiate between failover and disaster recovery. Failover is a methodology to resume system availability
in an acceptable period of time, while disaster recovery is a methodology to resume system availability when allfailover strategies have failed.
No Failover Strategy
With no failover strategy in place your Caché database integrity is still protected from production system failure. Structural database integrity is maintained by Caché write image journal (WIJ) technology; you cannot disable this. Logical integrity is maintained through global journaling and transaction processing. While global journaling can be disabled and transaction processing is optional, InterSystems highly recommends using them.
If a production system failure occurs, such as a hardware failure, the database and application are generally unaffected. Disk degradation, of course, is an exception. Disk redundancy and good backup procedures are vital to mitigate problems arising from disk failure.
Failover Cluster
A common and often inexpensive approach to recovery after failure is to maintain a standby system to assume the production workload in the event of a production system failure. A typical configuration has two identical computers with shared access to a disk subsystem.
After a failure, the standby system takes over the applications formerly running on the failed system. Microsoft Windows Clusters, HP MC/ServiceGuard, Tru64 UNIX® TruClusters, OpenVMS Clusters, and IBM HACMP provide a common approach for implementing failover cluster. In these technologies, the standby system senses a heartbeat from the production
system on a frequent and regular basis. If the heartbeat consistently stops for a period of time, the standby system automatically assumes the IP address and the disk formerly associated with the failed system. The standby can then run any applications (Caché, for example) that were on the failed system. In this scenario, when the standby system takes over the application, it executes a pre-configured start script to bring the databases online. Users can then reconnect to the databases that are now running on the standby server. Again, WIJ, global journaling, and transaction processing are used to maintain structural and data integrity.
To be continued
No comments:
Post a Comment